Allacrost Demo Public Release

Let our staff know what you think about the game and suggest improvements

Moderator: Staff

Viliam
Contributor
Posts: 35
Joined: Tue Sep 05, 2006 10:25 pm
Location: Bratislava, Slovakia
Contact:

Postby Viliam » Sat Dec 16, 2006 2:33 am

By the way... when I play Glest, there is an item in menu called "API info", and it displays:

Code: Select all

OpenGL info:
Version: 2.0.3
Renderer: GeForce FX 5500 / AGP / SSE2 / 3DNOW!
Vendor: NVIDIA Corporation
Max lights: 8
Max texture size: 4096
Max texture units: 4
Modelview matrix stack depth: 32
Projection matrix stack depth: 4


Now this is what I was writing about... finally I know which version of OpenGL I have, so if some problem would happen with another game, I would just send this info and ask "is your game supposed to run on this?". I do not know what those numbers mean, but the programmers would probably have some idea and say "yes, this should be ok" or "no, you need matrix stack depth 128 or more, or you need 64 and have to turn off special effects". So at least I would know whether the problem is with graphics card / driver, or something else.
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Postby Roots » Sat Dec 16, 2006 10:21 am

Actually there is a way to do this in Allacrost. If you run Allacrost and supply the -i option on the command line, then it will print out info about your system to the console. Of course, Windows has a very crappy command-line interface so we'll probably have to add this option in the boot menu. *sigh*, I wish Windows just never existed to begin with. :axe:
Image
KingHanco
Newbie
Posts: 14
Joined: Thu Jul 19, 2007 10:36 pm
Location: Fort Worth, TX USA

Postby KingHanco » Sat Jul 21, 2007 5:13 pm

This game rocks!

I'm using Ubuntu to run the demo,

I have Intel 4 3.20ghz with Ati Radeon 9550 256mb graphics card,

Here is game installer setup that I done.

Code: Select all

Hero of Allacrost

deb http://debian.ettin.org/allacrost etch-backports main
sudo wget http://debian.ettin.org/key.gpg -O - | sudo apt-key add -
sudo apt-get install allacrost-demo


Anyway I can't wait for the 0.2.1 release. Let us know when it is release, :approve:

Btw: Keep up the good work on this game. :bow:

Infos.

Code: Select all

mitchell@pc-desktop:~$ cd /usr/games/; ./allacrost -i

===== System Information
SDL version (compiled):  1.2.11
SDL version (linked):    1.2.11
Number of joysticks found:  1
  Joystick #0
    Joystick Name: GreenAsia Inc.    USB Joystick     
    Number Axes: 7
    Number Buttons: 12
    Number Trackballs: 0
    Number Hat Switches: 0

===== Video Information
SDL_ttf version (compiled): 2.0.8
Name of video driver: x11
  Best available video mode
    Creates hardware surfaces: no
    Has window manager available: yes
    Hardware to hardware blits accelerated: no
    Hardware to hardware colorkey blits accelerated: no
    Hardware to hardware alpha blits accelerated: no
    Software to hardware blits acceleerated: no
    Software to hardware colorkey blits accelerated: no
    Software to hardware alpha blits accelerated: no
    Color fills accelerated: no
    Total video memory: 0 kilobytes

===== Audio Information
SDL_mixer version (compiled): 1.2.6
SDL_mixer version (linked):   1.2.6
Number of playback channels:  2
Number of mixing channels:  8
Playback frequency:  22050
Playback format:  32784
Maximum volume:  128
Last edited by KingHanco on Thu Aug 23, 2007 8:35 pm, edited 1 time in total.
User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Postby gorzuate » Mon Jul 23, 2007 5:37 pm

Glad you like it :D
Image
KingHanco
Newbie
Posts: 14
Joined: Thu Jul 19, 2007 10:36 pm
Location: Fort Worth, TX USA

Postby KingHanco » Tue Jul 31, 2007 9:37 pm

deb http://debian.ettin.org/allacrost unstable main

Is this the newer version? For testing. I saw some changes.
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Postby Roots » Tue Jul 31, 2007 10:55 pm

Both unstable and testing should contain the same version (0.2.0 demo). If you saw any changes, they were likely just package fixes; the game itself has not been updated.
Image
KingHanco
Newbie
Posts: 14
Joined: Thu Jul 19, 2007 10:36 pm
Location: Fort Worth, TX USA

Postby KingHanco » Wed Aug 01, 2007 4:01 am

The shop in stable doesn't have a message come up.

But unstable does have a shop that have a message come up.

The message doesn't have a picture on it.

I see what you mean there. Yep the stable haven't been updated.
KingHanco
Newbie
Posts: 14
Joined: Thu Jul 19, 2007 10:36 pm
Location: Fort Worth, TX USA

Postby KingHanco » Fri Aug 03, 2007 6:02 am

I no longer can download the unstable anymore.

Ubuntu uses new files now.

Code: Select all

allacrost-demo:
  Depends: libc6 (>=2.5-5) but 2.5-0ubuntu14 is to be installed
  Depends: libgcc1 (>=1:4.2-20070516) but 1:4.1.2-0ubuntu4 is to be installed
  Depends: libstdc++6 (>=4.2-20070516) but 4.1.2-0ubuntu4 is to be installed


Stable download still working. I hope it won't be broken because I want Ubuntu let me know there is a update that I need to download to replace 2.0. I will be upset if it does get broken to where I can't get the newer version.
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Postby Roots » Fri Aug 03, 2007 6:57 am

AFAIK, the unstable version never worked in Ubuntu to begin with, due to differences in a libc version or something. The unstable and testing/stable distributions are always synchronized with the latest release, so don't worry.
Image

Return to “User Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest