Will not install or anything on new Ubuntu. =(

For those having trouble installing/running the game or to report a bug

Moderator: Staff

KingHanco
Newbie
Posts: 14
Joined: Thu Jul 19, 2007 10:36 pm
Location: Fort Worth, TX USA

Will not install or anything on new Ubuntu. =(

Postby KingHanco » Mon Sep 29, 2008 7:42 pm

User avatar
Roots
Dictator
Posts: 8664
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Will not install or anything on new Ubuntu. =(

Postby Roots » Mon Sep 29, 2008 8:55 pm

Thanks, we'll look into it. Sounds like it might be a missing dependency in the Debian package.
Image
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 9:23 pm

Re: Will not install or anything on new Ubuntu. =(

Postby ettin » Mon Sep 29, 2008 9:43 pm

KingHanco wrote:http://ubuntuforums.org/showthread.php?p=5876997#post5876997

You are using and old repo, see: http://www.allacrost.org/download

Roots wrote:Thanks, we'll look into it. Sounds like it might be a missing dependency in the Debian package.

Hmm, not sure about that... he is trying to install from source. Anyway, both libqt4-dev and libqt4-opengl-dev are listed as build-dependencies in the Debian package.

(Note that I haven't tested if the package actually works on Ubuntu; if someone has successfully installed it, please let me know.)
Winter Knight
Contributor
Posts: 304
Joined: Fri Sep 21, 2007 12:35 pm
Contact:

Re: Will not install or anything on new Ubuntu. =(

Postby Winter Knight » Tue Sep 30, 2008 9:26 am

I tested the Debian package on Debian Testing, and it seems to work just fine. I posted a response on the Ubuntu thread. The problem is partly that the OP made some mistakes and misunderstood the instructions, and partly that half the responses in the thread wouldn't even work in Ubuntu Hardy.

It is worthy of note that the debian binary for the editor will not work out of the box in Hardy, because it requires newer Qt libraries than Hardy provides. libqt-opengl and libqt-opengl-dev are not even available in Hardy. It might work if the user also put the hardy-backports into their sources.list.

I recommend compiling from source if you want to install Allacrost on Ubuntu. The OP already has the source, and I think he'll be OK now.

I learned that Allacrost builds the editor by default now. I guess I can stop adding the --enable-editor to the configure line.
User avatar
Roots
Dictator
Posts: 8664
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Will not install or anything on new Ubuntu. =(

Postby Roots » Tue Sep 30, 2008 4:58 pm

Winter Knight wrote:I learned that Allacrost builds the editor by default now. I guess I can stop adding the --enable-editor to the configure line.


That's correct. I changed the default value of this option to true since we will be distributing the editor with the game releases from now on. If for some reason you ever want to not tell configure to compile the game editor, I think you can add --enable-editor=false to the configure line.
Image
User avatar
MindFlayer
Developer
Posts: 688
Joined: Fri Jan 06, 2006 12:55 pm
Location: Kuopio / Tampere, Finland
Contact:

Re: Will not install or anything on new Ubuntu. =(

Postby MindFlayer » Wed Oct 01, 2008 7:47 am

I think I found some small issues from the Debian installation instructions on http://www.allacrost.org/download

shouldn't this

Code: Select all

sudo apt-get update && apt-get install allacrost-demo

be like this instead?

Code: Select all

sudo apt-get update && sudo apt-get install allacrost-demo


Also, the line "deb http://debian.ettin.org/allacrost unstable main.," looks very confusing with the ending dot, please remove it. :)
LastOS
Newbie
Posts: 1
Joined: Wed May 19, 2010 9:04 am

Re: Will not install or anything on new Ubuntu. =(

Postby LastOS » Wed May 19, 2010 9:58 am

Is this project dead?

I added the repo and gpg key expecting to install this with synaptic but libluabind0 isn't on the repositorys only libluabind0.9.0 is which causes unmet dependencies in ubuntu 10.04 lucid.

After I managed to manually install the game it errors when run with:

/usr/games/allacrost: error while loading shared libraries: libluabind.so.0: cannot open shared object file: No such file or directory

I really want a Turn-Based RPG game available to Ubuntu, cause most are real time battles. Just hoping that one of the devs here will consider making the repository function with a clean Ubuntu 10.04 so I can get more involved with it's development. I'm not a deb packaging expert yet, but can code.

Subscribed to this thread, let me know what I can try please?
User avatar
Roots
Dictator
Posts: 8664
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Will not install or anything on new Ubuntu. =(

Postby Roots » Fri May 21, 2010 2:50 am

No we're not dead. We just have only a handful of people committed to continuing work on the project right now and pretty much every one of us is busy with other things in our lives.

Are you trying to install the latest trunk build, the latest official release (which is well over a year old), or the latest unofficial release? If you're installing the latest official release, I believe you need Luabind 0.8. The latest unofficial release and trunk both migrated to Luabind 0.9 if I remember correctly. I know that we've had some issues with Ubuntu before because they don't update their Luabind packages as quickly as Debian does. I run Debian unstable which has the Luabind 0.9 package. Worst case scenario is that you'll have to build the Luabind library yourself. Yes, the library is a constant thorn in our side for the build process and compatibility, but it works excellent once you actually have it built successfully. :)


Our debian packager is ettin and he's usually idle in our IRC channel. You might want to try to get in touch with him if you're having issues with the package, although I haven't heard from him in months. Hope this information is a good start for you. Let me know if that helps or if you have any more questions. Oh and BTW, there's a large difference between the latest official release and the latest unofficial release (there's no Debian package for the later); They are practically two different games. So if you're new to Allacrost you may want to give both of them a try. Thanks!
Image
rujasu
Developer
Posts: 758
Joined: Sun Feb 25, 2007 5:40 am
Location: Maryland, USA

Re: Will not install or anything on new Ubuntu. =(

Postby rujasu » Fri May 21, 2010 3:53 am

If you're interested in development you may want to check out the current SVN version:

http://allacrost.sourceforge.net/wiki/i ... Repository

The reason I suggest this is that it should actually run better than the last unstable release, which crashes too much. I've had few if any crashes on the current revision, and some of the minor issues have been ironed out.

In any case, thanks for your interest in the project! If you'd like to help with development let us know, we're open to any contributions.

Return to “Technical Issues”

Who is online

Users browsing this forum: No registered users and 1 guest