Text not displayed in Ubuntu

For those having trouble installing/running the game or to report a bug

Moderator: Staff

Post Reply
nemesis
Senior Member
Posts: 157
Joined: Fri Apr 29, 2011 7:53 am
Location: Sachsen/Germany

Text not displayed in Ubuntu

Post by nemesis » Wed May 04, 2011 4:56 pm

So, finally I compiled allacrost (checkout from the demo folder). Although I can run a play the game, most of the texts are not displayed, however, some are.

Example:
Title screen (boot.cpp) -> Demo ... and 2004 - 2010 ... is displayed, but non of the options, i.e. all text added by AddOption() is not displayed (e.g. "New Game").
Dialogs -> No text displayed but pictures are there.
Game -> "Pause" is displayed
Inventory -> Name of the active Region (e.g. Desert Outskirts) is shown, but nothing else.
Battle -> Claudius, HP and SP (also the numbers) are shown, nothing else
-> pressing the attack button, "Attack" is writte below the symbol, nothing else
-> Target selection, probaly everything is displayed

Everything else works, so battle is okay, changing maps is okay, talking to people is okay (except that I cannot read the text).

I use Ubuntu (Windows installer) and just installed most all missing packages.

Does anyone had this problem before?
User avatar
Roots
Dictator
Posts: 8668
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Text not displayed in Ubuntu

Post by Roots » Wed May 04, 2011 5:14 pm

That sounds really weird. I'm running Ubuntu as well (10.10) and downloaded the demo a little over a week ago (clean install of OS) and I did not have that problem at all. Do you have the SDL_ttf library? The game technically shouldn't allow you to compile it if it can't be found...

Try running Allacrost from the command line like so:

"./allacrost -d all"

And look for any messages it writes to the terminal.
Image
nemesis
Senior Member
Posts: 157
Joined: Fri Apr 29, 2011 7:53 am
Location: Sachsen/Germany

Re: Text not displayed in Ubuntu

Post by nemesis » Wed May 04, 2011 5:25 pm

Thanks for your reply.

First also I though it was a problem of SDL_ttf, but all load font-definitions are valid. I can change the font for "Demo 1.0.0" in the title to all defined name and it works. I can set the text for AddOptions to all registered fonts, and nothing works.

Debugging I tried, but tried. Beside some errors regarding ALSA (I though it was removed from the project??) that I always get (also without debug), the only warning I get is

WARNING:src/common/gui/textbox.cpp:_ReformatText:301: textbox font is invalid.
(2 times)
nemesis
Senior Member
Posts: 157
Joined: Fri Apr 29, 2011 7:53 am
Location: Sachsen/Germany

Re: Text not displayed in Ubuntu

Post by nemesis » Wed May 04, 2011 5:33 pm

Okay, forget about everything.

It was some hardware problem. :shrug:

I installed new drives for my graphic card, now everthing is fine. :cool:
User avatar
Roots
Dictator
Posts: 8668
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Text not displayed in Ubuntu

Post by Roots » Wed May 04, 2011 5:35 pm

Phew, okay good. I was worried there for a second. :heh:
Image
Post Reply