Page 1 of 1

Wiki is MIA

Posted: Mon Apr 25, 2011 3:44 pm
by Roots
Hey guys, what happened to our wiki? I tried to access it today and all I get is a blank page.

http://allacrost.sourceforge.net/wiki/i ... /Main_Page


Has it been like this for a while? I can look into moving the wiki to our own site instead of our Sourceforge space if we need to (I know we discussed doing this a few months ago). Let me know if that's something I should do.

Re: Wiki is MIA

Posted: Mon Apr 25, 2011 7:37 pm
by rujasu
It was working a few weeks ago when I looked at it. No idea what's wrong with it now.

There's definitely some valuable info on it, though there's also a lot of outdated stuff. If it's going to continue to be intermittent, then moving it to a new host might be a good idea, maybe even pare it down to just the few pages that are useful and cut the rest. I don't know if it's really worth putting too much effort into, though.

Re: Wiki is MIA

Posted: Mon Apr 25, 2011 8:11 pm
by Roots
Well what I care most about is the code documentation there. That is very useful information (and not too outdated either) and I was hoping to review it to refresh my memory about how everything in the engine works. I'll look around and see what I can do to bring it back, even if only in a partial capacity.

Re: Wiki is MIA

Posted: Mon Apr 25, 2011 9:32 pm
by rujasu
Agreed, the code documentation we have is pretty valuable, even though it's kind of limited.

Re: Wiki is MIA

Posted: Thu May 05, 2011 12:32 pm
by Roots
I spoke with SF support today. They believe the issue was caused by their February web system space upgrade. Other projects have reported the same problem with their MediaWiki instances and resolved them by updating their MW version (we're currently using a very old version). All of our data is still intact so that's not lost.


Rather than try and update the old installation, I'm going to install the latest MediaWiki on our own server and try to migrate our data to the new install. We had planned to move the wiki over to our main site eventually anyway, since its a small headache to host it at sourceforge. I'll continue to post updates here on this progress.

Re: Wiki is MIA

Posted: Thu May 05, 2011 1:52 pm
by Roots
I'm pretty sure an automated migration is going to be nearly impossible. We'd have to transfer the databases over somehow and I just don't see that working out. We'll probably have to transfer all the pages over manually, which will be a PITA.


I do have the latest MediaWiki software installed on our site now, although I'm having some trouble setting up the ShortURL redirects at the moment. I think for now I'm going to backup our sourceforge wiki install and then do an upgrade of the software over there. I may gradually begin migrating pages over to our local site wiki sometime later.

Re: Wiki is MIA

Posted: Thu May 05, 2011 3:47 pm
by Roots
http://allacrost.sourceforge.net/wiki/i ... /Main_Page

Wiki is back up. Yay! :D


The bad news is if you try to make any edits, it fails and you get an error. I don't plan on fixing this now though. I think its wiser to just port the old wiki content over to the new one, which I'll do piece by piece (throwing out the old/unused pieces along the way). At the very least, I'm going to create skeleton pages for all the pages we'll need to port over and once I've done that, I'll let you guys in on where the new wiki can be accessed and hopefully I can have some help during this massive migration. :angel: