bug: 0000173: Big resolutions don't display correctly

For discussion of the code running behind the game

Moderator: Staff

Guthur
Newbie
Posts: 8
Joined: Sat Dec 13, 2008 9:53 pm

bug: 0000173: Big resolutions don't display correctly

Postby Guthur » Sun Dec 14, 2008 1:24 am

I actually have an idea to what this might be, though i could easily be wrong as I have yet to even look at a code file :)

bug:
http://bugs.allacrost.org/view.php?id=173

relevant info:
http://allacrost.sourceforge.net/wiki/index.php/Map_Mode#Coordinate_System

The resolutions would appear to have to be a power of 2, the reason I could connect this to that problem was because when i read it i immediately worried about widescreen resolutions which can be odd aspect ratios.

eg: (res = tile divisions)(assuming a pixel square of 16x16) 1920x1080 = 120 x 67.5 - not cool and probably the reason parts are being cut off. gorzuate i suspect your TV is an odd res as well.
To be honest if this is the case its down to the fact of too much coupling between these coordinate systems (collision, graphics, screen).

Proposed Solution (if this is the cause):
Letter boxing the odd screen resolutions ie. adding black areas on the edges of the screen to round the res to what we want.
To try any other solution, e.g. decoupling the coordinate systems, would involve far to much effort I would imagine.

I might look further into this for concrete proof once i get some code files :)

Michael

Edit: Reason i posted here was; no bug tracker access, plus would rather discuss first as i have limited exposure to the engine

Edit: Ok its not a a power of two issue because the default isn't one, but i'll start looking at code now and see. I thnk it will be something related.

Return to “Programming”

Who is online

Users browsing this forum: Google [Bot] and 6 guests